xubuntu10.04 3.2.32-34 visu à problème

Questions techniques et conseils pour Linux et Mac OS. Réactions, expériences, questions, c'est ici.

Modérateurs: Modérateurs, Mod GNU/Linux

Règles du forum
Image Merci de lire les règlements du forum avant de poster.

Image Rappel: Le langage SMS n'est pas toléré sur ce forum. Les demandes d'aide écrites en SMS ou formulées dans un français trop approximatif ne seront pas traitées.
Publicité

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede jmnpb2000 » 26 Nov 2011 23:43

Bonsoir
tia² a écrit:il faut optimiser le "/etc/X11/xorg.conf". Tu peux le créer avec un

Code: Tout sélectionner
gksudo gedit

alors ça j'ai essayé avant mais ça ne faisait rien.
Je suppose que
Code: Tout sélectionner
sudo vi
fonctionne.
tia² a écrit:Ensuite, tu y mets ceci en remplaçant les valeurs par ta vraie définition

Code: Tout sélectionner
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection

Je ne mets que cela dans le (nouveau) xorg.conf? Ou bien je dois recopier le XF86Config.sample?
DE plus l'écran est 16/9 et non pas 4/3 et la résolution recommandée est 1366x768. Je laisse tout de même
Code: Tout sélectionner
Modes        "1024x768" "800x600" "640x480"
?

tia² a écrit:Que donne "lsmod"?

Alors, pour l'instant (avant toute manip de création de xorg.conf) ça donne:
Code: Tout sélectionner
Module                  Size  Used by
nouveau               467048  0
ttm                    50103  1 nouveau
drm_kms_helper         29329  1 nouveau
drm                   162377  3 nouveau,ttm,drm_kms_helper
i2c_algo_bit            5028  1 nouveau
ipt_REJECT              1928  1
ipt_LOG                 4542  5
xt_multiport            2378  1
xt_limit                1382  7
xt_tcpudp               2011  17
ipt_addrtype            1599  4
xt_state                1098  7
snd_via82xx            20058  6
ip6table_filter         1248  1
gameport                9089  1 snd_via82xx
ip6_tables             11102  1 ip6table_filter
snd_via82xx_modem       8486  2
snd_ac97_codec        100646  2 snd_via82xx,snd_via82xx_modem
ac97_bus                1002  1 snd_ac97_codec
nf_nat_irc              1124  0
snd_pcm_oss            35308  0
snd_mixer_oss          13746  3 snd_pcm_oss
snd_pcm                70694  4 snd_via82xx,snd_via82xx_modem,snd_ac97_codec,snd_pcm_oss
nf_conntrack_irc        3332  1 nf_nat_irc
snd_mpu401_uart         5617  1 snd_via82xx
nf_nat_ftp              1836  0
snd_seq_dummy           1338  0
nf_nat                 15560  2 nf_nat_irc,nf_nat_ftp
nls_iso8859_1           3249  1
snd_seq_oss            26722  0
nf_conntrack_ipv4      10346  9 nf_nat
nf_defrag_ipv4          1073  1 nf_conntrack_ipv4
nls_cp437               4919  1
snd_seq_midi            4557  0
nf_conntrack_ftp        5381  1 nf_nat_ftp
snd_rawmidi            19056  2 snd_mpu401_uart,snd_seq_midi
nf_conntrack           60975  7 xt_state,nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_nat,nf_conntrack_ipv4,nf_conntrack_ftp
vfat                    8933  1
snd_seq_midi_event      6003  2 snd_seq_oss,snd_seq_midi
fat                    47767  1 vfat
iptable_filter          1369  1
nvidia               3908089  0
snd_seq                47263  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
fbcon                  35102  71
tileblit                1999  1 fbcon
font                    7557  1 fbcon
snd_timer              19098  2 snd_pcm,snd_seq
ip_tables               9899  1 iptable_filter
bitblit                 4707  1 fbcon
softcursor              1189  1 bitblit
snd_seq_device          5700  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
x_tables               14175  9 ipt_REJECT,ipt_LOG,xt_multiport,xt_limit,xt_tcpudp,ipt_addrtype,xt_state,ip6_tables,ip_tables
cdc_ether               3541  0
vga16fb                11385  1
snd                    54244  24 snd_via82xx,snd_via82xx_modem,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_mpu401_uart,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
vgastate                8961  1 vga16fb
usbnet                 14943  1 cdc_ether
psmouse                63677  0
ppdev                   5259  0
via686a                11050  0
via_agp                 5310  1
lp                      7028  0
mii                     4381  1 usbnet
serio_raw               3978  0
snd_page_alloc          7076  3 snd_via82xx,snd_via82xx_modem,snd_pcm
soundcore               6620  3 snd
i2c_viapro              5573  0
parport_pc             25962  1
shpchp                 28835  0
agpgart                31724  4 ttm,drm,nvidia,via_agp
parport                32635  3 ppdev,lp,parport_pc
pata_via                7272  4

tia² a écrit:Qu'y a t'il dans "XF86Config.sample"?

C'est le fichier suivant:
Code: Tout sélectionner
##########################################################################
# Sample XF86Config file for NVIDIA XFree86 drivers.
#
# Refer to the XF86Config(4/5) man page for details about the format of
# this file.
#
# Be sure to replace the monitor values with correct values for your
# monitor!
##########################################################################


Section "Files"

    RgbPath   "/usr/X11R6/lib/X11/rgb"
    FontPath   "unix/:-1"

EndSection


##########################################################################
# Server flags section.
##########################################################################

Section "ServerFlags"

    # Uncomment this to cause a core dump at the spot where a signal is
    # received.  This may leave the console in an unusable state, but may
    # provide a better stack trace in the core dump to aid in debugging
    #NoTrapSignals

    # Uncomment this to disable the <Crtl><Alt><BS> server abort sequence
    # This allows clients to receive this key event.
    #DontZap

    # Uncomment this to disable the <Crtl><Alt><KP_+>/<KP_-> mode switching
    # sequences.  This allows clients to receive these key events.
    #DontZoom

    # This  allows  the  server  to start up even if the
    # mouse device can't be opened/initialised.
    AllowMouseOpenFail

EndSection


##########################################################################
# Input devices
##########################################################################

#
# Keyboard section
#
Section "InputDevice"

    Identifier "Keyboard1"
    Driver     "Keyboard"
    Option     "AutoRepeat"  "250 30"

    Option "XkbRules"  "xfree86"
    Option "XkbModel"  "pc105"
    Option "XkbLayout" "us"

EndSection


#
# Pointer section
#
Section "InputDevice"

    Identifier  "Mouse1"
    Driver      "mouse"
    Option      "Protocol"    "IMPS/2"
    Option      "Device"      "/dev/psaux"

EndSection


##########################################################################
# Module section
##########################################################################

Section "Module"

    Load        "dbe"

    # Load the glx module.
    Load   "glx"

    Load        "extmod"

    Load   "type1"
    Load   "freetype"
EndSection


##########################################################################
# Monitor section
##########################################################################

Section "Monitor"

    Identifier "MyMonitor"
    VendorName "Mitsubisi"
    ModelName  "Diamond Plus 120u"

    # be sure to replace these values with values appropriate for your
    # monitor!
    HorizSync  31-82
    VertRefresh 55-120

    # 3840x2400 @ 12Hz for IBM's T221 FlatPanel
    Modeline "3840x2400" 148.0 3840 3944 4328 4816 2400 2401 2404 2418

EndSection


##########################################################################
# Graphics device section(s)
##########################################################################

Section "Device"
    Identifier  "NV AGP"
    VendorName  "nvidia"
    Driver   "nvidia"
    # update this with the PCI id of your card.  Consult the output
    # of the 'lspci' command.  The BusID is usually optional when
    # only using one graphics card.
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
    Identifier "NV PCI"
    VendorName "nvidia"
    Driver "nvidia"
    # update this with the PCI id of your card.  Consult the output
    # of the 'lspci' command.  The BusID is usually optional when
    # only using one graphics card.
    BusID       "PCI:0:13:0"
EndSection

Section "Device"
    Identifier "NV AGP TwinView"
    VendorName "nvidia"
    Driver "nvidia"
    # update this with the PCI id of your card.  Consult the output
    # of the 'lspci' command. The  BusID is usually optional when
    # only using one graphics card.
    BusID       "PCI:1:0:0"

    # sample twinview setup
    Option "TwinView"
    # be sure to replace the HorizSync and VertRefresh with correct values
    # for your monitor! 
    Option "SecondMonitorHorizSync"   "31-82"
    Option "SecondMonitorVertRefresh" "55-120"
    Option "TwinViewOrientation"      "RightOf"
    Option "MetaModes"                "1280x1024,1280x1024; 1024x768,1024x768"
    Option "ConnectedMonitor"         "crt,crt"
EndSection


##########################################################################
# Screen sections
##########################################################################

#
# screen section for an nvidia AGP card
#
Section "Screen"
    Identifier "Screen AGP"
    Device      "NV AGP"
    Monitor     "MyMonitor"
    DefaultColorDepth 24
    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x400"
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection

EndSection


#
# screen section for an nvidia PCI card
#
Section "Screen"
    Identifier "Screen PCI"
    Device      "NV PCI"
    Monitor     "MyMonitor"
    DefaultColorDepth 24
    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x400"
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
EndSection

#
# screen section for an nvidia AGP TwinView card
# (look at the appropriate Device section)
#
Section "Screen"
    Identifier "Screen AGP TwinView"
    Device "NV AGP TwinView"
    Monitor "MyMonitor"
    DefaultColorDepth 24
    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x400"
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
EndSection


##########################################################################
# ServerLayout sections
# (invoke using the '-layout' option of 'startx'.
##########################################################################

#
# just one agp card
#
Section "ServerLayout"
    Identifier  "AGP"
    Screen      "Screen AGP"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

#
# just one pci card
#
Section "ServerLayout"
    Identifier  "PCI"
    Screen      "Screen PCI"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

#
# 2 cards, non twinview
#
Section "ServerLayout"
    Identifier  "Both"
    Screen      "Screen AGP"
    Screen      "Screen PCI" LeftOf "Screen AGP"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

#
# just one agp twinview card
#
Section "ServerLayout"
    Identifier  "AGPTwinView"
    Screen      "Screen AGP TwinView"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

#
# 2 cards, one agp twinview and one pci (3 monitors total)
#
Section "ServerLayout"
    Identifier  "BothTwinView"
    Screen      "Screen AGP TwinView"
    Screen      "Screen PCI" LeftOf "Screen AGP TwinView"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

C'est un gros et je me demande si je dois le prendre en bloc dans xorg.conf en adaptant la sous section "Display", ou si je peux me limiter dansle nouveau xorg.conf à cette sous section Display.
Bonne soirée, et merci encore.
jmnpb2000
jmnpb2000
Accro
Accro
 
Messages: 203
Inscription: 13 Nov 2010 9:37

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede jmnpb2000 » 27 Nov 2011 9:05

Bonjour

alors j'ai essayé de créer un /etc/X11/xorg.conf avec seulement les 4 lignes en question, mais alors au redémarrage il n'y a plus que la mire ubuntu et tout est bloqué, ctrl-alt-F1 ne marche pas.. J'ai alors redémarré en mod dépannage, et en console admin j'ai détruit le /etc/X11/xorg.conf que je venais de créer, et tout est rentré dans l'ordre.

Je suppose donc qu'il faut copier XF86Config.sample dans xorg.conf et adapter ligne à ligne.
Entrer dans Google la recherche
Code: Tout sélectionner
xorg.conf Hyundai monitor
donne quelques pistes, arf.

En allant sur http://xtiming.sourceforge.net/cgi-bin/xtiming.pl
et en rentrant les specs trouvées sur le site du fabriquant (31-83 kHz horiz sync rate, 56-75Hz vertical sync rate=refresh rate?, ), j'obtiens
Code: Tout sélectionner
Modeline "1360x768@60" 84.50 1360 1392 1712 1744 768 783 791 807
mais ce qui m'inquiète est que si je laisse blanc certains champs dont je ne suis pas sûr (la plupart) en le laissant optimiser j'obtiens autre chose...

De plus je suis passé par le menu Applications->paramètres->éditeurs de paramètres et dans displays j'ai changé la propriété Default/Screen_0/Resolution de 1024x768 à 1366x768; mais en redémarrant ça ne change pas grand chose, j'ai toujours une visu aplatie, les cercles sont des ellipses. Je peux m'en tirant uniquement en appuyant sur le menu du moniteur lui même et en mettant la résolution en native, mais alors j'ai 2 bandes noires sur la gauche et la droite de l'écran.

Enfin en regardant http://doc.ubuntu-fr.org/nvidia.run j'ai lu que pour configurer automatiquement le serveur X (ce qui ne s'est pas fait) c'est l'utilitaire nvidia-xconfig qui est à la manoeuvre. J'ai bien cet utilitaire dans mon système, mais si je fais par exemple
Code: Tout sélectionner
nvidia-xconfig -t
il me dit
Warning: unable to locate/open Xconfig file

De fait, nvidia-xconfig prend en entrée soit /etc/X11/xorg.conf (qui n'existe pas dans mon système) si le serveur X utilisé est X.org, et /etc/X11/XF86Config (qui n'existe pas non plus dans mon système, mais dont j'ai un échantillon dans /usr/share/doc/NVIDIA_GLX-1.0/XF86Config.sample) si on utilise le serveur X XFree86.

Bref, apparemment mon serveur X fonctionne sans fichier de configuration, ou du moins je ne sais pas où il est. En plus je ne sais même pas si j'ai un serveur X X.org ou XFree86... :heu?: Je n'ai pas de .xinitrc dans mon répertoire home, mais j'ai un fichier .nvidia-settings-rc créé apparemment à chaque session et ne contenant pas grand chose d'intéressant...
Code: Tout sélectionner
# Configuration file for nvidia-settings - the NVIDIA X Server Settings utility
# Generated on Sun Nov 27 18:43:10 2011
#

# ConfigProperties:

RcFileLocale = C
ToolTips = Yes
DisplayStatusBar = Yes
SliderTextEntries = Yes
IncludeDisplayNameInConfigFile = No
ShowQuitDialog = Yes

# Attributes:


Il y a aussi un /etc/X11/xinit/xinitrc qui ne contient qu'une ligne non commentée:
Code: Tout sélectionner
./etc/X11/Xsession


Bref je patauge un peu. tout ce que je veux c'est avoir un bon facteur de forme 16:9 sur mon écran, alors que ce qui arrive semble adapté au 4:3 et se retrouve écrasé d'un facteur 4:3 pour occuper tout l'écran.

jmnpb2000
jmnpb2000
Accro
Accro
 
Messages: 203
Inscription: 13 Nov 2010 9:37

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede tia² » 27 Nov 2011 21:38

salut,
mais que fait encore "nouveau" dans les modules, merdel de borde! Par contre, je suis assez étonnée de voir que tu as quand même une session graphique. Pas tout compris là. Ais, tu peux pas savoir à quel point c'est plaisant de voir que toi aussi tu cherches. :)
Dis voir, as tu essayé de donner les définitions de modeline à xorg.conf?
Code: Tout sélectionner
SubSection "Display"
Depth 24
Modes "1360x768" "1392x783" "1712x791" "1744x807"
EndSubSection


Bon courage, :)
Rien ne sert de penser, il faut réfléchir avant.
Avatar de l’utilisateur
tia²
Mod Linux
Mod Linux
 
Messages: 355
Inscription: 20 Mai 2010 19:24
Localisation: Normandie du nord

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede jmnpb2000 » 27 Nov 2011 22:05

'Soir
tia² a écrit:Par contre, je suis assez étonnée de voir que tu as quand même une session graphique

Oui j'ai l'impression d'être malgré tout verni, je n'ai rien de ce qu'il faut en principe mais ça marche quand même, il doit y avoir un comportement par défaut à l'oeuvre.
tia² a écrit:Dis voir, as tu essayé de donner les définitions de modeline à xorg.conf?
Code: Tout sélectionner
SubSection "Display"
Depth 24
Modes "1360x768" "1392x783" "1712x791" "1744x807"
EndSubSection

Ben oui j'avais il y a 2 messages essayé de ne mettre que la subsection "Display" dans un fichier xorg.conf mais alors plus rien ne marchait, seulement la mire xubuntu.

est-ce à dire que je dois prendre le XF86Config entier, en faire une copie dans /etc/X11/xorg.conf (ou plutôt /etc/X11/XF86Config?) puis modifier dans ce nouveau fichier seulement la ligne Modes comme tu l'indiques?

Dans ce cas je dois aussi modifier tout un tas de paramètres: le nom du fabriquant, le type, la synchro horizontale,etc. etc.
Set puis le XF86Config commence par
Code: Tout sélectionner
RgbPath   "/usr/X11R6/lib/X11/rgb"

alors que je n'ai pas de répertoire /usr/X11R6...
et en plus je modifie la Subsection Display dans la Section Screen associée à la carte nvidia AGP ou la carte nvidia PCI?

Bon j'essaye quand même
A bientôt :bye:
jmnpb2000
Dernière édition par jmnpb2000 le 27 Nov 2011 22:49, édité 1 fois.
jmnpb2000
Accro
Accro
 
Messages: 203
Inscription: 13 Nov 2010 9:37

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede jmnpb2000 » 27 Nov 2011 22:43

Bonsoir
alors j'ai créé le fichier /etc/X11/XF86Config à partir du sample dans /usr/share/doc, et modifié dedans, tant la ligne modeline selon les recommandations du site http://xtiming.sourceforge.net/cgi-bin/xtiming.pl et aussi en modifiant comme tu m'as dit les lignes "Display" dans XF86COnfig (mais pas xorg.conf, que je n'ai pas créé)
tia² a écrit:Code: Tout sélectionner
SubSection "Display"
Depth 24
Modes "1360x768" "1392x783" "1712x791" "1744x807"
EndSubSection


Résultat; BOUM. J'ai eu un message d'erreur au redémarrage:
Code: Tout sélectionner
EE Failed to load /usr/lib/xorg/modules/drivers/nvidia_drv.so
EE Failed to load module "nvidia" (loader failed, 7)
EE Failed to load module kbd (module does not exist)
EE No drives available

Puis il me propose de démarrer en basse résolution pour cette session, ce que j'ai validé.

ALors je retrouve mon environnement aplati habituel... Un changement tout de même, il a créé un xorg.conf.failsafe dans /etc/X11!
Code: Tout sélectionner
Section "Device"
   Identifier   "Configured Video Device"
   Driver      "vesa"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection


Bizarre bizarre. Ce fichier vient d'être créé.
Bon, en tout cas pour éviter les ennuis j'ai renommé mon XF86COnfig XF86Config.2011-11-27 comme cela j'espère qu'il ne sera plus pris en compte. Et au nouveau redémarrage, je retrouve l'environnement aplati habituel sans message d'insultes au démarrage. Peut-être en plus basse résolution , par exemple le bandeau bleu de connexion n'apparaît plus quand je suis connecté sous informatruc, et j'ai aussi l 'impression que les choses sont un peu plus floues, mais ce n'est peut-être qu'une impression.

Voilà voilà.
jmnpb2000
jmnpb2000
Accro
Accro
 
Messages: 203
Inscription: 13 Nov 2010 9:37

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede tia² » 27 Nov 2011 22:58

salut,
rha la la, c'est vraiment galère les pilotes graphiques.

As tu un fichier ".config/monitors.xml" si oui, que contient 'il?

@+
Rien ne sert de penser, il faut réfléchir avant.
Avatar de l’utilisateur
tia²
Mod Linux
Mod Linux
 
Messages: 355
Inscription: 20 Mai 2010 19:24
Localisation: Normandie du nord

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede jmnpb2000 » 28 Nov 2011 20:32

Bonsoir
tia² a écrit:As tu un fichier ".config/monitors.xml" si oui, que contient 'il?

heu, dans quel répertoire?
Dans /etc ou /etc/X11, ni .config, ni monitor, ni .config.xml, ni monitor.xml
J'ai par contre dans /etc/X11 un Xwrapper.config et c'est tout. Depuis /etc/X11, un
Code: Tout sélectionner
find . -name *config* -print
ne donne rien d'autre et
Code: Tout sélectionner
find . -name *monitor* -print
ne donne rien.
Depuis /etc, le 1er find ne trouve que manpath.config, et le second trouve ./init/udevmonitor.conf et ./init.d/udevmonitor
Comme il y a des répertoires où il y a des permissions refusées, j'ai essayé les mêmes find avec sudo depuis /etc: résultat des courses: idem, seulement manpath.config et les 2 *udevmonitor*
Sinon dans /etc les seuls fichiers se terminant par xml sont le répertoire /etc/xml et don contenu
Voilà voilà...
Où dois-je chercher ces fameux fichiers?
jmnpb2000
jmnpb2000
Accro
Accro
 
Messages: 203
Inscription: 13 Nov 2010 9:37

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede tia² » 28 Nov 2011 21:26

salut,
erf, quelle blonde! C'est dans ton home. Je ne sais pas si ce fichier existe sous Lucid.

@+
Rien ne sert de penser, il faut réfléchir avant.
Avatar de l’utilisateur
tia²
Mod Linux
Mod Linux
 
Messages: 355
Inscription: 20 Mai 2010 19:24
Localisation: Normandie du nord

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede jmnpb2000 » 28 Nov 2011 21:50

Bonsoir
tia² a écrit:C'est dans ton home

Arf :oops:
Bien, oui dans mon home il y a un dossier .config mais il ne contient pas de fichier monitors.xml: il contient des fichiers texte Trolltech.conf, user-dirs.dirs et user-dirs.locale, et des dossires autostart, enchant, exaile, gtk-2.0, ibus, mousepad, QuantumGIS, ristretto, softwarecenter, Thunar, totem, vlc, xfce4. Dans xfce4 il y a un dossier xfconf contenant un dossier xfce-perchannel-xml contenant des fichiers xml dont un displays.xml :
Code: Tout sélectionner
<?xml version="1.0" encoding="UTF-8"?>

<channel name="displays" version="1.0">
  <property name="Default" type="empty">
    <property name="Layout" type="string" value="Screens"/>
    <property name="NumScreens" type="int" value="1"/>
    <property name="Screen_0" type="empty">
      <property name="Resolution" type="string" value="1366x768"/>
      <property name="RefreshRate" type="int" value="0"/>
      <property name="Rotation" type="int" value="0"/>
    </property>
  </property>
</channel>

Je ne sais pas si c'est pertinent...
jmnpb2000
Accro
Accro
 
Messages: 203
Inscription: 13 Nov 2010 9:37

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede tia² » 28 Nov 2011 22:27

bonsoir,
d'ac, pas de monitors.xml…alors que tu devrais en avoir un.
Que donne même si je pense qu'on va retrouver le modeline :
Code: Tout sélectionner
xrandr



Zou au dodo, j'ai les yeux qui piquent. @+
Rien ne sert de penser, il faut réfléchir avant.
Avatar de l’utilisateur
tia²
Mod Linux
Mod Linux
 
Messages: 355
Inscription: 20 Mai 2010 19:24
Localisation: Normandie du nord

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede jmnpb2000 » 29 Nov 2011 20:14

Bonsoir
alors
Code: Tout sélectionner
xrandr

donne
Code: Tout sélectionner
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0*
   800x600         0.0 
   640x480         0.0 

J'ai essayé
Code: Tout sélectionner
xrandr --fb 1360x768
mais il me dit que
Code: Tout sélectionner
xrandr: screen cannot be larger than 1024x768 (desired size 1360x768)

Damned.
jmnpb2000
jmnpb2000
Accro
Accro
 
Messages: 203
Inscription: 13 Nov 2010 9:37

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede tia² » 29 Nov 2011 22:32

bonsoir,
erf, si le pilote vesa ne donne pas la bonne définition, c'est pas gagné.
Tu vas même essayer de reconfigurer. Il ne faut pas qu'il y ait un fichier nommé "/etc/X11/xorg.conf", si tu en as, un renomme le.
Tu fermes ta session, tu passes en tty, tu quittes gdm
Code: Tout sélectionner
sudo service gdm stop

Tu reconfigures
Code: Tout sélectionner
sudo X -configure

Puis, tu vas installer le xorg.conf créé.
Code: Tout sélectionner
sudo mv ~/xorg.conf.new /etc/X11/xorg.conf

Tu redémarres par un "sudo reboot"

En fait, c'est vesa qui pose problème.

@+
Rien ne sert de penser, il faut réfléchir avant.
Avatar de l’utilisateur
tia²
Mod Linux
Mod Linux
 
Messages: 355
Inscription: 20 Mai 2010 19:24
Localisation: Normandie du nord

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede jmnpb2000 » 30 Nov 2011 20:07

Bonsoir
Merci de ta patience :oops:
tia² a écrit:Tu vas même essayer de reconfigurer. Il ne faut pas qu'il y ait un fichier nommé "/etc/X11/xorg.conf", si tu en as, un renomme le.

Pas de fichier xorg.conf dans /etc/X11, ok
tia² a écrit:Tu fermes ta session, tu passes en tty, tu quittes gdm

Code: Tout sélectionner
sudo service gdm stop

j'ai fait
Code: Tout sélectionner
sudo service gdm stop
il a arrêté l'inerface graphique, j'ai alors fait ctrl alt F1 et me suis loggé
tia² a écrit:Tu reconfigures

Code: Tout sélectionner
sudo X -configure

Depuis ma session tty j'ai fait cela mais alors j'ai eu un message d'erreur:Configuration failed
Cependant il m'a bien créé un xorg.conf.new, ci après:
Code: Tout sélectionner
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/X11/misc"
   FontPath     "/usr/share/fonts/X11/cyrillic"
   FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/Type1"
   FontPath     "/usr/share/fonts/X11/100dpi"
   FontPath     "/usr/share/fonts/X11/75dpi"
   FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
   FontPath     "built-ins"
EndSection

Section "Module"
   Load  "dri"
   Load  "dbe"
   Load  "record"
   Load  "extmod"
   Load  "glx"
   Load  "dri2"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "HWcursor"              # [<bool>]
        #Option     "NoAccel"               # [<bool>]
        #Option     "ShadowFB"              # [<bool>]
        #Option     "VideoKey"              # <i>
        #Option     "EXAPixmaps"            # [<bool>]
   Identifier  "Card0"
   Driver      "nouveau"
   VendorName  "nVidia Corporation"
   BoardName   "NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection



Je me suis dit, bah essayons quand même et je l'ai donc renommé xorg.conf dans /etc/X11 puis ai fait un
Code: Tout sélectionner
sudo reboot

Alors là j'ai eu un message:
Code: Tout sélectionner
ubuntu fonctionne en mode graphique basse résolution
L'erreur suivante est survenue, vous avez peut-ête nesoin de mettre à jour votre configuration afin de résoudre cela.
(EE) [drm] KMS not enabled
(EE) No devices detected

Puis il m'a proposé une liste de choix avec le 1er coché:
Code: Tout sélectionner
x Lancer Ubuntu en mode basse résolution uniquement pour cette session
o Reconfigurer paramètres graphiques
o Réparer l'erreur
o Quitter vers le mode console
o Relancer l'interface graphique


J'ai donc lancé ubuntu en mode basse résolution et je retrouve mon ubuntu un peu aplati.

Mesure d'urgence, j'enlève le xorg.conf en le renommant autre chose?
jmnpb2000
jmnpb2000
Accro
Accro
 
Messages: 203
Inscription: 13 Nov 2010 9:37

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede jmnpb2000 » 30 Nov 2011 20:30

Rebonsoir
bon, j'ai essayé dans le xorg.conf de comenter la ligne load "dri", puis ai redémarré: alors là j'ai eu d nouveau la mire xubuntu avec rien d'autre, pas de contrôle, rien. Je me suis donc reconnecté en mode console, ai renommé mon xorg.conf xorg.conf.2011-11-30 puis ai redémarré, et là mon ubuntu aplati est revenu.
Apparemment le xorg.conf pose des soucis quand il est dans /etc/X11. :saispas:
jmnpb2000
jmnpb2000
Accro
Accro
 
Messages: 203
Inscription: 13 Nov 2010 9:37

Re: xubuntu10.04 3.2.32-34 visu à problème

Messagede tia² » 30 Nov 2011 22:22

bonsoir,
rha la la, c'est n'imp' ce fichier. Tu peux le renommer.
Avais tu essayé ceci avec "xrandr"
Code: Tout sélectionner
xrandr --newmode "1360x768_60" 84.50 1360 1392 1712 1744 768 783 791 807 -hsync +vsync
xrandr --addmode default "1024x768_60"
xrandr --output default --mode "1024x768_60"

Si ça foire, on va tenter un dernier truc pour configurer xorg.conf. Tu vas y mettre ceci :
Code: Tout sélectionner

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
    Modeline "1360x768_60" 84.50 1360 1392 1712 1744 768 783 791 807  -HSync +Vsync
EndSection

Section "Screen"
    Identifier      "Default Screen"
    Monitor         "Monitor0"
    Device          "Card0"
    DefaultDepth    24
    SubSection "Display"
        Depth        16
        Modes        "1360x768""1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1360x768""1024x768" "800x600" "640x480"
    EndSubSection
EndSection


Si ça foire, bah, tu connais le chemin du forum. ;)

@+
Rien ne sert de penser, il faut réfléchir avant.
Avatar de l’utilisateur
tia²
Mod Linux
Mod Linux
 
Messages: 355
Inscription: 20 Mai 2010 19:24
Localisation: Normandie du nord

PrécédenteSuivante

Retourner vers Problèmes avec tous les autres OS: Linux, Mac OS ...

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité